Back to overview
Downtime

All of our self-hosted services are currently down due to an issue.

Mar 28 at 10:03pm GMT
Affected services
Company Website
King's Game Group API
King's Game Group Links

Resolved
Mar 28 at 10:40pm GMT

We have sucessfully rebooted the server and all services are back online, thanks for bearing with us.

Created
Mar 28 at 10:03pm GMT

Due to an issue with our server infrastructure, all of our self-hosted services are currently experiencing downtime, this includes our website, internal website, API, CDN, redirects and internal CDN.